Ticket #118 (closed enhancement: fixed)

Opened 7 years ago

Last modified 6 years ago

Scan remote codes from Telldus Live!

Reported by: stefan persson <stefan.persson@…> Owned by: stefan persson <stefan.persson@…>
Priority: major Milestone: 2.1.2
Component: Telldus Live! Version: 2.1.0
Keywords: Cc:
Blocked By: Blocking:
Platform: Other Sensitive: no
Verified by Telldus: yes

Description

Changes needed both for Telldus Live! on the web, and for the API.

Attachments

93098956.png Download (39.0 KB) - added by bob foster <smartmil888@…> 3 years ago.
 http://smartmiltoys.com/kidkraft-train-table/

Change History

comment:1 Changed 7 years ago by micke prag <micke.prag@…>

We also need some good comet-solution:
 http://en.wikipedia.org/wiki/Comet_(programming)

comment:2 Changed 7 years ago by stefan persson <stefan.persson@…>

  • Verified by Telldus unset
  • Milestone changed from 2.1.2 to 2.1.1

Make a quick, poll-based basic solution first.

comment:3 Changed 7 years ago by patrik åkerfeldt <patrik.akerfeldt@…>

(This is my initial thought coming from an API user perspective)

Would a solution similar with that of learning physical devices today? I.e. you pretty much say to the Live! API: "Please associate this device with an additional code". Perhaps the Tellstick device LED flashes to indicate that it is accepting a new code (just like the Nexa devices). This will also indicate that it does not accept yet another association command until a timeout expires or the user transmits a signal. I press ON on my physical controller and Live! associates the code with the chosen device.

Using the API I would like to be able to trigger such association/learning and I would also like to get a list of current codes associated with a device as well as remove individual codes.

How does it sound?

comment:4 Changed 7 years ago by micke prag <micke.prag@…>

  • Verified by Telldus set
  • Component changed from other to Telldus Live!

comment:5 Changed 6 years ago by stefan persson <stefan.persson@…>

  • Owner changed from telldus technologies <info.tech@…> to stefan persson <stefan.persson@…>
  • Sensitive unset
  • Status changed from new to assigned

comment:6 Changed 6 years ago by torbjorn pettersson <torbjorn@…>

Any progress?

Would be nice to get some place (e.g. new tab) where one could read code from remote control into Live! For example to enable reading of house code from Nexa remote controls.

The idea above with "API I would like to be able to trigger such association/learning and I would also like to get a list of current codes associated with a device as well as remove individual codes." sounds grate!

comment:7 Changed 6 years ago by micke prag <micke.prag@…>

This ticket has been referenced in ticket #274:

Duplicate of #118

comment:8 Changed 6 years ago by julian alder <julian@…>

I would be very interested in beta testing any enhancements you make in reading Motion or magnetic sensors. Both of these are essential for creating remote Tellstick net based security applications and especially useful when linked with text based alerts or even remote heating controls.

Thank you
Julian

comment:9 Changed 6 years ago by stefan persson <stefan.persson@…>

  • Status changed from assigned to closed
  • Resolution set to fixed

Changed 3 years ago by bob foster <smartmil888@…>

Note: See TracTickets for help on using tickets.