Ticket #311 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Compile fail on ArchLinux

Reported by: hans olav talgø <hans.olav.talgo@…> Owned by:
Priority: major Milestone:
Component: telldus-core Version: 2.1.1
Keywords: Cc:
Blocked By: Blocking:
Platform: Linux Sensitive: no
Verified by Telldus: no

Description

Hi

I tried to compile telldus-core from the trunk of the git repo, but got a number of compiler errors when compiling service/EventUpdateManager.cpp of this kind:
EventUpdateManager.cpp:182:7: error: ‘environ’ was not declared in this scope

I'm on an up to date Arch Linux
I locally updated service/EventUpdateManager.cpp to include unistd.h and the compile worked fine.

This seems like a similar bug.as #216

Hans Olav

Change History

comment:1 Changed 6 years ago by micke prag <micke.prag@…>

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #313

Note: See TracTickets for help on using tickets.